阿里云服务器ReLinuxBash严重漏洞修复图文教程

刚刚收到阿里云服务器的通知,说linux系统官方内置Bash中发现一个非常严重安全漏洞,请务必及时修复,看了一些论坛的修复教程(教程链接:http://bbs.aliyun.com/read/176977.html)好多人不知道怎么修复,下面我就为此整理一个图文教程吧, 我的是Aliyun Linux 5.4 64bit 的系统,大家可以对照自己的系统进行操作。

1、升级前大家记得备份一下系统快照,我的备份命令是:
wget http://mirrors.aliyun.com/centos/5/updates/x86_64/RPMS/bash-3.2-33.el5.1.x86_64.rpm && rpm -Uvh bash-3.2-33.el5.1.x86_64.rpm   (不同的系统,命令不一样,请参考上面的链接)

 

2、检查系统是否存在此漏洞的命令为:
env x='() { :;}; echo vulnerable’ bash -c “echo this is a test”
输入后提示如下图代码,就说明有此漏洞

1

 

3、通过以下命令进行修复
yum -y update bash
直到命令结束后,出现如下图:

2

 

 

4、再运行监测漏洞的命令
env x='() { :;}; echo vulnerable’ bash -c “echo this is a test”
出现如下图所示代码就证明修复成功了。
3

5、然后重启服务器,等几分钟就可以了!命令:reboot (要注意阿里云需要一定时间才能重启)
4

 

关于作者

杰夫(jerfo0)

杰夫(jerfo0)

一个活的真实,耿直的boy。
坚定相信爱情,向往自由,对世界充满好奇心。热爱美剧、海贼王、一切户外运动、旅行...
职业:互联网运营。
生命不息,折腾不止,燥起来!!

查看全部帖子

发表评论

邮箱地址不会被公开。 必填项已用*标注